summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gtk.scm12
-rw-r--r--gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch28
3 files changed, 0 insertions, 41 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c6cacd7ada..1332efdcff 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -876,7 +876,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch	\
   %D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
   %D%/packages/patches/gtk2-theme-paths.patch			\
-  %D%/packages/patches/gtk3-fix-deprecation-macro-use.patch	\
   %D%/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch	\
   %D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
   %D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7527abbbac..6e63ca6614 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -822,18 +822,6 @@ application suites.")
            (variable "GUIX_GTK3_PATH")
            (files '("lib/gtk-3.0")))))))
 
-;; Fixes a bug in Gtk that causes crashes in IceCat and Emacs.
-;; See <https://bugs.gnu.org/34454>, <https://bugs.gnu.org/34658>,
-;; and <https://gitlab.gnome.org/GNOME/gtk/issues/1523>.
-(define gtk+/fixed
-  (package
-    (inherit gtk+)
-    (source (origin
-              (inherit (package-source gtk+))
-              (patches
-               (cons (search-patch "gtk3-fix-deprecation-macro-use.patch")
-                     (origin-patches (package-source gtk+))))))))
-
 ;;;
 ;;; Guile bindings.
 ;;;
diff --git a/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch b/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch
deleted file mode 100644
index e933555ffb..0000000000
--- a/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Copied from <https://gitlab.gnome.org/GNOME/gtk/commit/e3a1593a>.
-Fixes upstream bugs <https://gitlab.gnome.org/GNOME/gtk/issues/1523>
-and <https://gitlab.gnome.org/GNOME/gtk/issues/1280>.
-
-diff --git a/gdk/x11/gdkwindow-x11.c b/gdk/x11/gdkwindow-x11.c
-index 97ada6d73919fba3dfe192dd66929e90bc7677bb..764e39495f7edb0c3efe41cca25b8bee4778887d 100644
---- a/gdk/x11/gdkwindow-x11.c
-+++ b/gdk/x11/gdkwindow-x11.c
-@@ -2985,6 +2985,7 @@ gdk_window_x11_set_background (GdkWindow      *window,
-   double r, g, b, a;
-   cairo_surface_t *surface;
-   cairo_matrix_t matrix;
-+  cairo_pattern_t *parent_relative_pattern;
- 
-   if (GDK_WINDOW_DESTROYED (window))
-     return;
-@@ -2997,8 +2998,10 @@ gdk_window_x11_set_background (GdkWindow      *window,
-     }
- 
- G_GNUC_BEGIN_IGNORE_DEPRECATIONS
--  if (pattern == gdk_x11_get_parent_relative_pattern ())
-+  parent_relative_pattern = gdk_x11_get_parent_relative_pattern ();
- G_GNUC_END_IGNORE_DEPRECATIONS
-+
-+  if (pattern == parent_relative_pattern)
-     {
-       GdkWindow *parent;
-