summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4cfc546c0..7ee139b990 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2663,6 +2663,14 @@ thanks to the use of namespaces.")
                   ;; Do not create directories in /var.
                   (substitute* "Makefile.in"
                     (("\\$\\(MAKE\\) .*install-data-hook") ""))
+
+                  ;; The original source overrides PATH so that it points to
+                  ;; /bin, /usr/local/bin, etc., which obviously doesn't work
+                  ;; on Guix System.  Leave PATH unchanged so we refer to the
+                  ;; installed Coreutils, grep, etc.
+                  (substitute* "bin/singularity.in"
+                    (("^PATH=.*" all)
+                     (string-append "#" all "\n")))
                   #t))))
     (build-system gnu-build-system)
     (arguments