summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index def9c23b17..336ad2ee13 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -186,6 +186,17 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                 (inputs (if (%current-target-system)
                             `(("bash" ,%bash-static))
                             '()))))
+	(tar (package (inherit tar)
+	       (arguments
+		'(#:phases (modify-phases %standard-phases
+			     (add-before 'build 'set-shell-file-name
+			       (lambda _
+				 ;; Do not use "/bin/sh" to run programs; see
+                                 ;; <http://lists.gnu.org/archive/html/guix-devel/2016-09/msg02272.html>.
+				 (substitute* "src/system.c"
+				   (("/bin/sh") "sh")
+				   (("execv ") "execvp "))
+				 #t)))))))
         (finalize (compose static-package
                            package-with-relocatable-glibc)))
     `(,@(map (match-lambda