summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5160bcf2ea..2498f6f39d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1999,9 +1999,9 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
     (build-system cmake-build-system)
     (arguments
      ;; Tests fail on all systems but x86_64.
-     `(#:tests? ,(string=? "x86_64-linux"
-                           (or (%current-target-system)
-                               (%current-system)))
+     `(#:tests? ,(string-prefix? "x86_64-"
+                                 (or (%current-target-system)
+                                     (%current-system)))
        #:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
        #:phases
        (modify-phases %standard-phases