summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 9c18a7ab39..135083ad22 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -52,7 +52,8 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (guix packages))
+  #:use-module (guix packages)
+  #:use-module (srfi srfi-1))
 
 (define-public libssh
   (package
@@ -265,6 +266,27 @@ programs written in GNU Guile interpreter.  It is a wrapper to the underlying
 libssh library.")
     (license license:gpl3+)))
 
+(define-public guile2.2-ssh
+  ;; This is a snapshot of a unofficial copy of Guile-SSH, which hopefully
+  ;; reflects the upcoming release well enough.
+  (let ((commit "926a0843626f89e3db02d01a6b01cc1f0d9cefcf")
+        (revision "0"))
+    (package
+      (inherit guile-ssh)
+      (name "guile2.2-ssh")
+      (version (string-append "0.10.2." revision "." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://notabug.org/civodul/guile-ssh/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0hf28macq8d1w05g0xy2lw1s5vzmcrixh7m43x7qvvdd31c998ip"))))
+      (inputs `(("guile" ,guile-2.2)
+                ,@(alist-delete "guile" (package-inputs guile-ssh)))))))
+
 (define-public corkscrew
   (package
     (name "corkscrew")