summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 58c6a902e2..dda4ce3ae3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5185,27 +5185,29 @@ supports arbitrary vertex/edge/graph attributes.")
 
 (define-public r-stabs
   (package
-  (name "r-stabs")
-  (version "0.6-3")
-  (source
-    (origin
-      (method url-fetch)
-      (uri (cran-uri "stabs" version))
-      (sha256
+    (name "r-stabs")
+    (version "0.6-4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "stabs" version))
+       (sha256
         (base32
-          "17sa0sjxf6h7gx1ga1pxhv17yrz3qisaivbf5cbc3asvshhswqg9"))))
-  (build-system r-build-system)
-  (home-page "https://github.com/hofnerb/stabs")
-  (synopsis "Stability selection with error control")
-  (description
-    "This package provides resampling procedures to assess the stability of
+         "1nf1yg14cgxrs4np1yghpzw1nczaslfv3rvf3918wrlzg0vp6l7q"))))
+    (build-system r-build-system)
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/hofnerb/stabs")
+    (synopsis "Stability selection with error control")
+    (description
+     "This package provides resampling procedures to assess the stability of
 selected variables with additional finite sample error control for
 high-dimensional variable selection procedures such as Lasso or boosting.
 Both, standard stability selection (Meinshausen & Buhlmann, 2010) and
 complementary pairs stability selection with improved error bounds
 (Shah & Samworth, 2013) are implemented.  The package can be combined with
 arbitrary user specified variable selection approaches.")
-  (license license:gpl2)))
+    (license license:gpl2)))
 
 (define-public r-rle
   (package