summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm3
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/linux.scm5
3 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b4f4d8ee06..5bf27c9ef1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -421,9 +421,6 @@ included.")
             ;; XXX: Work around "undefined reference to `__stack_chk_guard'".
             "libc_cv_ssp=no")
 
-      ;; Using '--strip-all' on crt*.o breaks them.
-      #:strip-flags '("--strip-debug")
-
       #:tests? #f                                 ; XXX
       #:phases (alist-cons-before
                 'configure 'pre-configure
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 309e195bc2..20831de997 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -170,10 +170,6 @@ identifier SYSTEM."
                    (ice-9 regex)
                    (srfi srfi-1)
                    (srfi srfi-26))
-
-        ;; Using '--strip-all' leads to a link failure while building libc.
-        #:strip-flags '("--strip-debug")
-
         ,@(substitute-keyword-arguments (package-arguments gcc-4.8)
             ((#:configure-flags flags)
              `(append (list ,(string-append "--target=" (boot-triplet))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 53368251b5..9dc5f5cd40 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -292,11 +292,6 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
                  (alist-replace
                   'install ,install-phase
                   (alist-delete 'configure %standard-phases)))
-
-       ;; Use '--strip-debug', not '--strip-all', because the latter leads to
-       ;; unloadable modules (due to the lack of a symbol table.)
-       #:strip-flags '("--strip-debug")
-
        #:tests? #f))
     (synopsis "100% free redistribution of a cleaned Linux kernel")
     (description