summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sdl.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 727a276dc5..df86d677ee 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -270,7 +270,18 @@ WEBP, XCF, XPM, and XV.")
          "--disable-music-flac-shared"
          "--disable-music-fluidsynth-shared"
          "--disable-music-mod-shared"
-         "--disable-music-ogg-shared")))
+         "--disable-music-ogg-shared")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-fluidsynth
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "configure"
+              (("EXTRA_LDFLAGS -lfluidsynth")
+               (string-append "EXTRA_LDFLAGS "
+                              "-L"
+                              (assoc-ref inputs "fluidsynth")
+                              "/lib -lfluidsynth")))
+             #t)))))
     (inputs
      `(("fluidsynth" ,fluidsynth)
        ("libflac" ,flac)