summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm2
-rw-r--r--gnu/packages/perl.scm2
-rw-r--r--gnu/packages/xml.scm2
3 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 234ea338a1..4684fce130 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -385,7 +385,7 @@ compression library.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   configure configure-zlib
+                   'configure 'configure-zlib
                    (lambda* (#:key inputs #:allow-other-keys)
                      (call-with-output-file "config.in"
                        (lambda (port)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 723b6d2d72..e55eb8791d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2486,7 +2486,7 @@ pseudo ttys.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   check disable-w32-test
+                   'check 'disable-w32-test
                    (lambda _
                      ;; This test fails, and we're not really interested in
                      ;; it, so disable it.
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 739f3fc384..d30c40ce1a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -245,7 +245,7 @@ checks.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   install augment-path
+                   'install 'augment-path
                    ;; The install target tries to load the newly-installed
                    ;; XML::SAX module, but can't find it, so we need to tell
                    ;; perl where to look.