summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c05a047615..d4a72df1d8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -812,6 +812,31 @@ alone or in concert with Non Timeline and Non Sequencer to form a complete
 studio.")
     (license license:gpl2+)))
 
+(define-public non-timeline
+  (package (inherit non-sequencer)
+    (name "non-timeline")
+    (arguments
+     (substitute-keyword-arguments (package-arguments non-sequencer)
+       ((#:configure-flags flags)
+        `(cons "--project=timeline"
+               (delete "--project=sequencer" ,flags)))))
+    (inputs
+     `(("jack" ,jack-1)
+       ("liblo" ,liblo)
+       ("libsndfile" ,libsndfile)
+       ("ntk" ,ntk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://non.tuxfamily.org/wiki/Non%20Timeline")
+    (synopsis "Modular digital audio timeline arranger")
+    (description
+     "The Non Timeline is a powerful, reliable and fast modular digital audio
+timeline arranger.  It utilizes JACK for inter-application audio I/O and the
+NTK GUI toolkit for a fast and lightweight user interface.  Non Timeline can
+be used alone or in concert with Non Mixer and Non Sequencer to form a
+complete studio.")
+    (license license:gpl2+)))
+
 (define-public solfege
   (package
     (name "solfege")