summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/orpheus.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/orpheus.scm b/gnu/packages/orpheus.scm
index 069d3e548a..f7912524c2 100644
--- a/gnu/packages/orpheus.scm
+++ b/gnu/packages/orpheus.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -62,7 +63,12 @@
             (setenv "SHELL" (which "bash"))
             (setenv "LIBS" "-logg")     ;doesn't declare its use of libogg
             (zero?
-             (system* "./configure" (string-append "--prefix=" out)))))
+             (system* "./configure" (string-append "--prefix=" out)
+                                    ,@(if (string=? "mips64el-linux"
+                                                    (%current-system))
+                                          '("--host=mips64el-unknown-linux-gnu")
+                                          '())
+                      ))))
         (alist-cons-after
          'configure 'configure-players
          (lambda* (#:key inputs #:allow-other-keys)