summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6e9ebc49f4..89bdfa6de1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4641,15 +4641,16 @@ userspace queueing component and the logging subsystem.")
   (package
     (name "proot")
     (version "5.1.0")
-    (home-page "https://github.com/proot-me/PRoot")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append home-page "/archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "11h30i83vdhc3khlj6hrh3a21sbmmz8nhfv09vkf6b9bcs1biz2h"))
-              (patches (search-patches "proot-test-fhs.patch"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/proot-me/PRoot.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0azsqis99gxldmbcg43girch85ysg4hwzf0h1b44bmapnsm89fbz"))
+       (patches (search-patches "proot-test-fhs.patch"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags '("-C" "src")
@@ -4726,6 +4727,7 @@ userspace queueing component and the logging subsystem.")
                      ;; For 'mcookie', used by some of the tests.
                      ("util-linux" ,util-linux)))
     (inputs `(("talloc" ,talloc)))
+    (home-page "https://github.com/proot-me/PRoot")
     (synopsis "Unprivileged chroot, bind mount, and binfmt_misc")
     (description
      "PRoot is a user-space implementation of @code{chroot}, @code{mount --bind},