summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b0ed51298f..34beb09f44 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1711,7 +1711,17 @@ follows a traditional multi-track tape recorder control paradigm.")
         (base32
          "1392spswkhfd38fggf584wb3m8aqpg7csfrs9zxnzyvhgmp0fgqk"))))
     (build-system waf-build-system)
-    (arguments `(#:tests? #f)) ; no tests
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-sse-flags
+           (lambda* (#:key system #:allow-other-keys)
+             (when (not (or (string-prefix? "x86_64" system)
+                            (string-prefix? "i686" system)))
+               (substitute* "wscript"
+                 (("'-msse', '-mfpmath=sse', ") ""))
+             #t))))
+       #:tests? #f)) ; no tests
     (inputs
      `(("lv2" ,lv2)
        ("lvtk" ,lvtk)