summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index dd590575a4..12e4de52d4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -606,7 +606,15 @@ included.")
            (add-after 'patch-source-shebangs 'patch-more-shebangs
              (lambda _
                (substitute* "gold/Makefile.in"
-                 (("/bin/sh") (which "sh")))))))))
+                 (("/bin/sh") (which "sh")))))
+           ;; Multiple failing tests on some architectures in the gold testsuite.
+           ,@(if (or (target-arm?)
+                     (target-ppc32?))
+               '((add-after 'unpack 'skip-gold-testsuite
+                   (lambda _
+                     (substitute* "gold/Makefile.in"
+                       ((" testsuite") " ")))))
+               '())))))
     (native-inputs
      `(("bc" ,bc)))))