summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocr.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index de321bb53f..7f12907927 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
-;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -142,7 +142,7 @@ monospaced or proportional.")
 (define-public gimagereader
   (package
     (name "gimagereader")
-    (version "3.3.1")
+    (version "3.4.0")
     (source
      (origin
        (method url-fetch)
@@ -151,24 +151,11 @@ monospaced or proportional.")
              "/download/v" version "/"
              "gimagereader-" version ".tar.xz"))
        (sha256
-        (base32 "1pghffb55k3wq33nbn9fi0lmjbldpmvqs2msnvss8bxz1k1ck23n"))))
+        (base32 "09glxh7b4ivrd4samm67b8k2p0aljiagr83wb8nvy5ps2a9gwp5m"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ;no test
-       #:configure-flags (list "-DENABLE_VERSIONCHECK=0")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-build
-           ;; XXX: Prevent compilation error: "incomplete type ‘QUrl’ used in
-           ;; nested name specifier".  Fixed upstream as
-           ;; 6209e25dab20b233e399ff36fabe4252db0f9e44.  It can be removed in
-           ;; release 3.3.2+.
-           (lambda _
-             (with-directory-excursion "qt/src/hocr"
-               (substitute* '("HOCROdtExporter.cc" "HOCRTextExporter.cc")
-                 (("#include <QMessageBox>\n" all)
-                  (string-append all "#include <QUrl>\n"))))
-             #t)))))
+       #:configure-flags (list "-DENABLE_VERSIONCHECK=0")))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("intltool" ,intltool)