summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9e8bbf97be..c4aa8b2a63 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2417,7 +2417,16 @@ exec " gcc "/bin/" program
             ;; The generated config.status has some problems due to the
             ;; bootstrap environment.  Disable dependency tracking to work
             ;; around it.
-            `(cons "--disable-dependency-tracking" ,flags))
+            `(cons "--disable-dependency-tracking"
+
+                   ;; 'glibc-bootstrap' on non-x86 platforms has a buggy
+                   ;; 'posix_spawn'.  Thus, disable it.  See
+                   ;; <https://bugs.gnu.org/49367>.
+                   ,(match (%current-system)
+                      ((or "i686-linux" "x86_64-linux")
+                       flags)
+                      (_
+                       `(cons "--disable-posix-spawn" ,flags)))))
            ((#:phases phases)
             `(modify-phases ,phases
                (replace 'build