summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 800e19d827..107d5b4a7c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -150,13 +150,13 @@ and security.")
 If present, pass EXTRA-ARGUMENTS to runtest as well."
   `(modify-phases %standard-phases
      (replace 'check
-       (let ((runtest
-              (string-append
-               (assoc-ref %build-inputs "trytond")
-               "/lib/python"
-               ,(version-major+minor (package-version python))
-               "/site-packages/trytond/tests/run-tests.py")))
-         (lambda* (#:key inputs outputs #:allow-other-keys)
+       (lambda* (#:key inputs outputs #:allow-other-keys)
+         (let ((runtest
+                (string-append
+                 (assoc-ref inputs "trytond")
+                 "/lib/python"
+                 ,(version-major+minor (package-version python))
+                 "/site-packages/trytond/tests/run-tests.py")))
            (add-installed-pythonpath inputs outputs)
            (invoke "python" runtest "-m" ,module ,@extra-arguments))))))