summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d2bf5b015b..714072e84b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1102,7 +1102,8 @@ converting QuarkXPress file format.  It supports versions 3.1 to 4.1.")
        ("flex" ,flex)
        ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)
-       ("which" ,which)))
+       ("which" ,which)
+       ("ziptime" ,ziptime)))
     (inputs
      `(("bluez" ,bluez)
        ("boost" ,boost)
@@ -1216,6 +1217,13 @@ converting QuarkXPress file format.  It supports versions 3.1 to 4.1.")
                                "/bin/xdg-open")))
 
              #t))
+         (add-after 'install 'reset-zip-timestamps
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (for-each (lambda (file)
+                           (invoke "ziptime" file))
+                         ;; So many different extensions for .zip files.
+                         (find-files out "\\.(bau|dat|otp|ott|zip)$")))))
          (add-after 'install 'bin-and-desktop-install
            ;; Create 'soffice' and 'libreoffice' symlinks to the executable
            ;; script.