summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 7e3c1aad1c..a43dfe89bd 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2623,6 +2623,29 @@ as USB mice.")
      "xf86-input-void is a null input driver for the Xorg X server.")
     (license license:x11)))
 
+(define-public xf86-video-amdgpu
+  (package
+    (name "xf86-video-amdgpu")
+    (version "18.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/driver/xf86-video-amdgpu-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+           "0wlnb929l3yqj4hdkzyxyhbaph13ac4villajgmbh66pa6xja7z1"))))
+    (build-system gnu-build-system)
+    (inputs `(("xorg-server" ,xorg-server)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://www.x.org/wiki/")
+    (synopsis "AMD Radeon video driver for X server")
+    (description
+     "xf86-video-amdgpu is an AMD Radeon video driver for the Xorg
+X server.")
+    (license license:x11)))
 
 (define-public xf86-video-ark
   (package