summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm12
-rw-r--r--gnu/packages/rust-apps.scm4
2 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8155bd7a94..82267687f9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5603,10 +5603,13 @@ values of all the exported APIs match the platform that libc is compiled for.")
       (origin
         (method url-fetch)
         (uri (crate-uri "libgit2-sys" version))
-        (file-name (string-append name "-" version ".crate"))
+        (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "0l9fvki7qxsl97vgzqwlv75nl213a5vxw7b1jaik97ala356pv6r"))))
+          "0l9fvki7qxsl97vgzqwlv75nl213a5vxw7b1jaik97ala356pv6r"))
+        (modules '((guix build utils)))
+        (snippet
+         '(begin (delete-file-recursively "libgit2") #t))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -5623,11 +5626,6 @@ values of all the exported APIs match the platform that libc is compiled for.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((openssl (assoc-ref inputs "openssl")))
                (setenv "OPENSSL_DIR" openssl))
-             (delete-file-recursively "libgit2")
-             (delete-file-recursively
-               (string-append "guix-vendor/rust-libgit2-sys-"
-                              ,(package-version rust-libgit2-sys-0.10)
-                              ".crate/libgit2"))
              (delete-file-recursively
                (string-append "guix-vendor/rust-libz-sys-"
                               ,(package-version rust-libz-sys-1.0)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8ad3c0ced4..1b0721f546 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -147,10 +147,6 @@ gitignore rules.")
                (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
                (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
                (delete-file-recursively
-                 (string-append "guix-vendor/rust-libgit2-sys-"
-                                ,(package-version rust-libgit2-sys-0.10)
-                                ".crate/libgit2"))
-               (delete-file-recursively
                  (string-append "guix-vendor/rust-libssh2-sys-"
                                 ,(package-version rust-libssh2-sys-0.2)
                                 ".crate/libssh2"))