summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sugar.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/sugar.scm b/gnu/packages/sugar.scm
index 35514263ff..3b40dddacd 100644
--- a/gnu/packages/sugar.scm
+++ b/gnu/packages/sugar.scm
@@ -75,15 +75,21 @@
                `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
     (inputs
      (list alsa-lib
-           gdk-pixbuf
-           gobject-introspection
            libice
-           (librsvg-for-system)
            libsm
            libx11
            libxfixes
            libxi
-           python
+           python))
+    (propagated-inputs
+     ;; The gi typelib files are needed by users of this library.
+     (list gdk-pixbuf
+           gobject-introspection
+           gtk+
+           (librsvg-for-system)
+
+           ;; This package is used as a Python library by users, so these must
+           ;; be propagated.
            python-dbus
            python-decorator
            python-pygobject
@@ -93,7 +99,6 @@
            gettext-minimal
            glib
            (list glib "bin")
-           gtk+
            intltool
            libtool
            pkg-config))