summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 4b81f59f1e..2192259612 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -461,11 +461,12 @@ created by PageMaker version 6.x and 7.")
        ("gperf" ,gperf)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("boost" ,boost)
-       ("icu4c" ,icu4c)
+    (propagated-inputs ; in Requires or Requires.private field of .pkg
+     `(("icu4c" ,icu4c)
        ("librevenge" ,librevenge)
        ("libxml2" ,libxml2)))
+    (inputs
+     `(("boost" ,boost)))
     ;; FIXME: Not needed any more for newer version 0.1.1.
     (arguments
      ;; avoid triggering a build failure due to warnings