summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index becd15d523..e5f990f7ab 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2386,8 +2386,10 @@ lookup to YAML Mode.  You could enable the mode with @code{(add-hook
                     (lambda* (#:key make-flags #:allow-other-keys)
                       (apply invoke "make" "-Csrc" make-flags)))
                   (replace 'check
-                    (lambda* (#:key make-flags #:allow-other-keys)
-                      (apply invoke "make" "-Ctests" make-flags)))
+                    (lambda* (#:key tests? make-flags #:allow-other-keys)
+                      (when tests?
+                        (apply invoke "make" "-Ctests" make-flags))
+                      #t))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))