summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/opencl.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 85b063b136..caafa6beaf 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -240,7 +240,10 @@ the system.")
        (list (string-append "-DCLANG_LIBRARY_DIR="
                             (assoc-ref %build-inputs "clang@3.7") "/lib")
              "-DENABLE_GL_SHARING=ON"
-             "-DEXPERIMENTAL_DOUBLE=ON")
+             "-DEXPERIMENTAL_DOUBLE=ON"
+             ;; disable OCL ICD, which is probably this project:
+             ;; https://github.com/OCL-dev/ocl-icd
+             "-DOCLICD_COMPAT=0")
 
        #:phases
        (modify-phases %standard-phases