summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 608d2c1648..9d05b2444e 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -671,6 +671,10 @@ libnvdimm (non-volatile memory device) sub-system in the Linux kernel.")
     (native-inputs `(("which" ,which)))
     (arguments
      `(#:tests? #f                      ; No tests.
+       ;; Prevent a race condition where some target would attempt to link
+       ;; libdmraid.so before it had been built as reported in
+       ;; <https://bugs.gnu.org/31999#187>.
+       #:parallel-build? #f
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'change-directory
                     (lambda _