summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 72637a7929..13006f3509 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1998,7 +1998,10 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
            #t))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ;tests fail on all systems but x86_64
+     ;; Tests fail on all systems but x86_64.
+     `(#:tests? ,(string=? "x86_64-linux"
+                           (or (%current-target-system)
+                               (%current-system)))
        #:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
        #:phases
        (modify-phases %standard-phases