summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b5070e7fda..44e3c14aa2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -323,24 +323,28 @@ datetime module, available in Python 2.3+.")
 (define-public python2-pysqlite
   (package
     (name "python2-pysqlite")
-    (version "2.6.3")
+    (version "2.6.3a")                            ; see below
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://pysqlite.googlecode.com/files/pysqlite-"
-                          version ".tar.gz"))
+      ;; During the switch from code.google.com to pypi.python.org, the 2.6.3
+      ;; tarball was modified, but the version number was kept:
+      ;; <https://lists.gnu.org/archive/html/guix-devel/2014-02/msg00077.html>.
+      ;; Here we want to refer to the pypi-hosted 2.6.3 tarball.
+      (uri (string-append
+            "https://pypi.python.org/packages/source/p/pysqlite/pysqlite-"
+            "2.6.3" ".tar.gz"))
       (sha256
        (base32
-        "0nsqqfp072rgqbls100rdvbzkjkin7li3kprhfxlfqvzf608hlqd"))))
+        "13djzgnbi71znjjyaw4nybg6smilgszcid646j5qav7mdchkb77y"))))
     (build-system python-build-system)
     (inputs
      `(("sqlite" ,sqlite)))
     (arguments
      `(#:python ,python-2 ; incompatible with Python 3
        #:tests? #f)) ; no test target
-    (home-page "http://labix.org/python-dateutil")
-    (synopsis
-     "SQLite bindings for Python.")
+    (home-page "https://pypi.python.org/pypi/pysqlite")
+    (synopsis "SQLite bindings for Python")
     (description
      "Pysqlite provides SQLite bindings for Python that comply to the
 Database API 2.0T.")