summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dictionaries.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index d7874936ee..965002a94d 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -223,6 +223,19 @@ It comes with a German-English dictionary with approximately 270,000 entries.")
         (base32
          "0jlzrhpx9qvjdq679w188p86x09yfjf3l0h4scjl9w26yyp53gr8"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-setup
+           ;; Fix typos in "setup.py".  In particular, add the new
+           ;; "graphspell" module introduced in 0.6.2.  Reported upstream:
+           ;; <https://www.dicollecte.org/thread.php?prj=fr&t=709>
+           (lambda _
+             (substitute* "setup.py"
+               (("packages=\\['grammalecte', 'grammalecte.fr'\\],")
+                "packages=['grammalecte', 'grammalecte.fr', 'grammalecte.graphspell'],")
+               (("_dictionaries/French.bdic") "graphspell/_dictionaries/fr.bdic"))
+             #t)))))
     (home-page "https://www.dicollecte.org")
     (synopsis  "French spelling and grammar checker")
     (description "Grammalecte is a grammar checker dedicated to the French