summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7704a555ed..4654a02491 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19706,29 +19706,27 @@ variable and the @code{minibuffer-line} face.")
     (license license:gpl3+)))
 
 (define-public emacs-eshell-prompt-extras
-  (let ((commit "5a328e1b9112c7f31ce2da7cde340f96626546b6")
-        (revision "1"))
-    (package
-      (name "emacs-eshell-prompt-extras")
-      (version (git-version "0.96" revision commit))
-      (home-page "https://github.com/zwild/eshell-prompt-extras")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url home-page)
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0fwlvrzjygs12dcp89wy3rb3wa03mrvbzpmpvmz4x6dfpr7csznk"))))
-      (build-system emacs-build-system)
-      (synopsis "Display extra information and color for your Eshell prompt")
-      (description "This library displays various customizable elements for
+  (package
+    (name "emacs-eshell-prompt-extras")
+    (version "1.0")
+    (home-page "https://github.com/zwild/eshell-prompt-extras")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0gb07mns23dgqqr6qfy7d6ndizy15sqgbgfaig6k5xbjnwi02v9g"))))
+    (build-system emacs-build-system)
+    (synopsis "Display extra information and color for your Eshell prompt")
+    (description "This library displays various customizable elements for
 @code{eshell} prompts: remote user, remote host, python virtual environment
 info, git branch, git dirty info and git unpushed number.  Multiple themes are
 available.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-eshell-did-you-mean
   (package