summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e5777d6d9..4cbffac000 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10548,7 +10548,7 @@ metrics, with methods for objects produced by the @code{methylumi} and
            (substitute* "src/Makevars"
              (("all: \\$\\(SHLIB\\)") "all:")
              (("\\$\\(SHLIB\\): liblzma.a") "")
-             (("(ZLIB|LZ4)/.*") "")
+             (("^	(ZLIB|LZ4)/.*") "")
              (("CoreArray/dVLIntGDS.cpp.*")
               "CoreArray/dVLIntGDS.cpp")
              (("CoreArray/dVLIntGDS.o.*")
@@ -10557,8 +10557,7 @@ metrics, with methods for objects produced by the @code{methylumi} and
               "PKG_LIBS = -llz4"))
            (substitute* "src/CoreArray/dStream.h"
              (("include \"../(ZLIB|LZ4|XZ/api)/(.*)\"" _ _ header)
-              (string-append "include <" header ">")))
-           #t))))
+              (string-append "include <" header ">")))))))
     (properties `((upstream-name . "gdsfmt")))
     (build-system r-build-system)
     (inputs