summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/pyqt-unbundled-qt.patch19
-rw-r--r--gnu/packages/qt.scm1
3 files changed, 21 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1fc916f6b3..7f690598c0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1253,6 +1253,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/pygpgme-disable-problematic-tests.patch  \
   %D%/packages/patches/pyqt-configure.patch			\
   %D%/packages/patches/pyqt-public-sip.patch			\
+  %D%/packages/patches/pyqt-unbundled-qt.patch			\
   %D%/packages/patches/python-2-deterministic-build-info.patch	\
   %D%/packages/patches/python-2.7-adjust-tests.patch		\
   %D%/packages/patches/python-2.7-search-paths.patch		\
diff --git a/gnu/packages/patches/pyqt-unbundled-qt.patch b/gnu/packages/patches/pyqt-unbundled-qt.patch
new file mode 100644
index 0000000000..5c91ed031c
--- /dev/null
+++ b/gnu/packages/patches/pyqt-unbundled-qt.patch
@@ -0,0 +1,19 @@
+Remove test for bundled Qt which breaks dependent applications.  This has
+been fixed in 5.13.
+
+Taken from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/python2-pyqt5-crash-fix.patch?h=packages/pyqt5&id=3e56e11d1fd7b1eac8242ce64c58db2bd9acba20
+
+diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
+--- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in        2019-06-25 14:41:02.000000000 +0200
++++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in       2019-07-01 17:06:34.882644535 +0200
+@@ -151,8 +151,4 @@
+     // initialised first (at least for Windows) and this is the only way to
+     // guarantee things are done in the right order.
+     PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
+-
+-    // Load the embedded qt.conf file if there is a bundled copy of Qt.
+-    if (!qpycore_qt_conf())
+-        Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
+ }
+
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a8b2bb40be..8928c1ddd4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1806,6 +1806,7 @@ module provides support functions to the automatically generated code.")
          (base32
           "041155bdzp57jy747p5d59740c55yy3241cy1x2lgcdsvqvzmc0d"))
        (patches (search-patches "pyqt-configure.patch"
+                                "pyqt-unbundled-qt.patch"
                                 "pyqt-public-sip.patch"))))
     (build-system gnu-build-system)
     (native-inputs