summary refs log tree commit diff
path: root/guix/build-system/cmake.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build-system/cmake.scm')
-rw-r--r--guix/build-system/cmake.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 2e6784251e..1bc1879be5 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -84,6 +84,7 @@
                       (tests? #t)
                       (test-target "test")
                       (parallel-build? #t) (parallel-tests? #f)
+                      (validate-runpath? #t)
                       (patch-shebangs? #t)
                       (strip-binaries? #t)
                       (strip-flags ''("--strip-debug"))
@@ -121,6 +122,7 @@ provides a 'CMakeLists.txt' file as its build system."
                     #:test-target ,test-target
                     #:parallel-build? ,parallel-build?
                     #:parallel-tests? ,parallel-tests?
+                    #:validate-runpath? ,validate-runpath?
                     #:patch-shebangs? ,patch-shebangs?
                     #:strip-binaries? ,strip-binaries?
                     #:strip-flags ,strip-flags