summary refs log tree commit diff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index 32b1f36a94..a97135fe0c 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -96,6 +96,7 @@ prepended to the name."
                        #:key
                        (python (default-python))
                        (tests? #t)
+                       (test-target "test")
                        (configure-flags ''())
                        (phases '(@ (guix build python-build-system)
                                    %standard-phases))
@@ -124,7 +125,7 @@ provides a 'setup.py' file as its build system."
                                    source)
                      #:configure-flags ,configure-flags
                      #:system ,system
-                     #:test-target "test"
+                     #:test-target ,test-target
                      #:tests? ,tests?
                      #:phases ,phases
                      #:outputs %outputs