summary refs log tree commit diff
path: root/mk/tests.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/tests.mk')
-rw-r--r--mk/tests.mk26
1 files changed, 0 insertions, 26 deletions
diff --git a/mk/tests.mk b/mk/tests.mk
deleted file mode 100644
index 004a480286..0000000000
--- a/mk/tests.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-# Run program $1 as part of ‘make installcheck’.
-define run-install-test
-
-  installcheck: $1
-
-  _installcheck-list += $1
-
-endef
-
-installcheck:
-	@total=0; failed=0; for i in $(_installcheck-list); do \
-	  total=$$((total + 1)); \
-	  echo "running test $$i"; \
-	  if (cd $$(dirname $$i) && $(tests-environment) $$(basename $$i)); then \
-	    echo "PASS: $$i"; \
-	  else \
-	    echo "FAIL: $$i"; \
-	    failed=$$((failed + 1)); \
-	  fi; \
-	done; \
-	if [ "$$failed" != 0 ]; then \
-	  echo "$$failed out of $$total tests failed "; \
-	  exit 1; \
-	fi
-
-.PHONY: check installcheck