summary refs log tree commit diff
path: root/nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix')
-rw-r--r--nix/local.mk4
-rw-r--r--nix/scripts/list-runtime-roots.in5
2 files changed, 6 insertions, 3 deletions
diff --git a/nix/local.mk b/nix/local.mk
index eb70d266fb..9e0c457bec 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -190,7 +190,7 @@ nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
 etc/guix-%.service: etc/guix-%.service.in	\
 			 $(top_builddir)/config.status
 	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";	\
-	$(SED) -e 's|@''bindir''@|$(bindir)|' <	\
+	$(SED) -e 's|@''localstatedir''@|$(localstatedir)|' <	\
 	       "$<" > "$@.tmp";		\
 	mv "$@.tmp" "$@"
 
@@ -201,7 +201,7 @@ nodist_upstartjob_DATA = etc/guix-daemon.conf etc/guix-publish.conf
 etc/guix-%.conf: etc/guix-%.conf.in	\
 			 $(top_builddir)/config.status
 	$(AM_V_GEN)$(MKDIR_P) "`dirname $@`";	\
-	$(SED) -e 's|@''bindir''@|$(bindir)|' <	\
+	$(SED) -e 's|@''localstatedir''@|$(localstatedir)|' <	\
 	       "$<" > "$@.tmp";		\
 	mv "$@.tmp" "$@"
 
diff --git a/nix/scripts/list-runtime-roots.in b/nix/scripts/list-runtime-roots.in
index 993eb169c1..a6938087b5 100644
--- a/nix/scripts/list-runtime-roots.in
+++ b/nix/scripts/list-runtime-roots.in
@@ -1,7 +1,7 @@
 #!@GUILE@ -ds
 !#
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -133,6 +133,9 @@ or the empty list."
         (define %file-rx
           (make-regexp "^n/(.*)$"))
 
+        ;; We're going to read it all.
+        (setvbuf pipe _IOFBF 16384)
+
         (let loop ((line  (read-line pipe))
                    (roots '()))
           (cond ((eof-object? line)