summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 39a628975a..1f31ffc6a5 100644
--- a/release.nix
+++ b/release.nix
@@ -86,6 +86,29 @@ let
         inherit succeedOnFailure keepBuildDirectory
           buildOutOfSourceTree;
       };
+
+
+    # Jobs to test the distro.
+    distro = {
+      hello =
+        { system ? builtins.currentSystem }:
+
+        let
+          pkgs = import nixpkgs { inherit system; };
+          guix = jobs.build { inherit system; };
+        in
+          # XXX: We have no way to tell the Nix to swallow the .drv
+          # produced by `guix-build', so we have a pointless indirection
+          # here.  This could be worked around by generating Nix code
+          # from the .drv, and importing that.
+          pkgs.releaseTools.nixBuild {
+            src = null;
+            phases = "buildPhase";
+            buildInputs = [ guix ];
+            buildPhase = "guix-build hello";
+            __noChroot = true;
+          };
+    };
   };
 in
   jobs