summary refs log tree commit diff
path: root/tests/repair.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tests/repair.sh')
-rw-r--r--tests/repair.sh65
1 files changed, 0 insertions, 65 deletions
diff --git a/tests/repair.sh b/tests/repair.sh
deleted file mode 100644
index ae82b649c6..0000000000
--- a/tests/repair.sh
+++ /dev/null
@@ -1,65 +0,0 @@
-source common.sh
-
-clearStore
-
-path=$(nix-build dependencies.nix -o $TEST_ROOT/result)
-path2=$(nix-store -qR $path | grep input-2)
-
-nix-store --verify --check-contents -v
-
-hash=$(nix-hash $path2)
-
-# Corrupt a path and check whether nix-build --repair can fix it.
-chmod u+w $path2
-touch $path2/bad
-
-if nix-store --verify --check-contents -v; then
-    echo "nix-store --verify succeeded unexpectedly" >&2
-    exit 1
-fi
-
-if nix-store --verify --check-contents --repair; then
-    echo "nix-store --verify --repair succeeded unexpectedly" >&2
-    exit 1
-fi
-
-nix-build dependencies.nix -o $TEST_ROOT/result --repair
-
-if [ "$(nix-hash $path2)" != "$hash" -o -e $path2/bad ]; then
-    echo "path not repaired properly" >&2
-    exit 1
-fi
-
-# Corrupt a path that has a substitute and check whether nix-store
-# --verify can fix it.
-clearCache
-
-nix-push --dest $cacheDir $path
-
-chmod u+w $path2
-rm -rf $path2
-
-nix-store --verify --check-contents --repair --option binary-caches "file://$cacheDir"
-
-if [ "$(nix-hash $path2)" != "$hash" -o -e $path2/bad ]; then
-    echo "path not repaired properly" >&2
-    exit 1
-fi
-
-# Check --verify-path and --repair-path.
-nix-store --verify-path $path2
-
-chmod u+w $path2
-rm -rf $path2
-
-if nix-store --verify-path $path2; then
-    echo "nix-store --verify-path succeeded unexpectedly" >&2
-    exit 1
-fi
-
-nix-store --repair-path $path2 --option binary-caches "file://$cacheDir"
-
-if [ "$(nix-hash $path2)" != "$hash" -o -e $path2/bad ]; then
-    echo "path not repaired properly" >&2
-    exit 1
-fi