From 4e735cccc7ca1c9ba8278df84b9351f1fa731e84 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 29 May 2022 02:00:01 +0200
Subject: gnu: irrlicht: Use CC-FOR-TARGET.

* gnu/packages/games.scm (irrlicht)[arguments]: Use CC-FOR-TARGET.
---
 gnu/packages/games.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c5c3e8af18..ed9f93b1a0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3588,7 +3588,9 @@ are primarily in English, however some in other languages are provided.")
                (mkdir-p (string-append out "/include")))))
          (delete 'configure))           ; no configure script
        #:tests? #f                      ; no check target
-       #:make-flags '("CC=gcc" "sharedlib")))
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             "sharedlib")))
     (inputs
      `(("bzip2" ,bzip2)
        ("libjpeg" ,libjpeg-turbo)
-- 
cgit 1.4.1