From 6646747c020402fd077a719af99627d9cf3fe54d Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Fri, 29 Aug 2014 18:28:50 -0400
Subject: gnu: gawk: Patch /usr/bin/file in extension/configure on MIPS.

* gnu/packages/gawk.scm (gawk): When building for MIPS, patch /usr/bin/file in
  extension/configure.
---
 gnu/packages/gawk.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index fd14b4c83e..84b5bd17a7 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -55,6 +55,14 @@
                           '((substitute* "extension/Makefile.in"
                               (("^.*: check-for-shared-lib-support" match)
                                (string-append "### " match))))
+                          '())
+
+                    ;; XXX FIXME prerelease libtool fails on MIPS in the
+                    ;; absence of /usr/bin/file.
+                    ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+                                                       (%current-system)))
+                          '((substitute* "extension/configure"
+                              (("/usr/bin/file") (which "file"))))
                           '())))
                 %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)
-- 
cgit 1.4.1