From f8bc5b13ad6b66f5efa4076495d11be7725f5279 Mon Sep 17 00:00:00 2001
From: Pavel Shlyak
Date: Tue, 27 Sep 2022 23:45:08 +0300
Subject: gnu: Add nm-tray.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
* gnu/packages/networking.scm (nm-tray): New variable.
Signed-off-by: Ludovic Courtès
---
gnu/packages/networking.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3489c3b96a..8311541b23 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Jesse Dowell
;;; Copyright © 2020 Hamzeh Nasajpour
;;; Copyright © 2020, 2022 Michael Rohleder
+;;; Copyright © 2021 Fakhri Sajadi
;;; Copyright © 2021 Hartmut Goebel
;;; Copyright © 2021 Justin Veilleux
;;; Copyright © 2021 Vinicius Monego
@@ -48,9 +49,11 @@
;;; Copyright © 2021 Guillaume Le Vaillant
;;; Copyright © 2021 Maxime Devos
;;; Copyright © 2022 Simon South
+;;; Copyright © 2022 Pavel Shlyak
;;; Copyright © 2022 Pierre Langlois
;;; Copyright © 2022 Petr Hodina
;;; Copyright © 2022 Manolis Fragkiskos Ragkousis
+;;; Copyright © 2022 Reza Alizadeh Majd
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,6 +83,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -115,6 +119,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
@@ -973,6 +978,33 @@ tasks.")
(home-page "https://github.com/blueman-project/blueman")
(license license:gpl3+)))
+(define-public nm-tray
+ (package
+ (name "nm-tray")
+ (version "0.5.0")
+ (home-page "https://github.com/palinek/nm-tray")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (sha256
+ (base32
+ "14i8sl0hrnyidlvqnxza0v4018f7p685ksn8419i2w7f9yqpvpiw"))
+ (file-name (git-file-name name version))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:tests? #f)) ;There are no tests upstream
+ (inputs (list qtbase-5 networkmanager-qt))
+ (native-inputs (list qttools-5 pkg-config))
+ (synopsis
+ "NetworkManager front-end with information icon residing in system tray")
+ (description
+ "nm-tray is a network connection management tool (NetworkManager
+front-end) with an information icon residing in the system tray. Unlike
+nm-applet, which is part of GNOME, this application is desktop-unaware.")
+ (license license:gpl2+)))
+
;; The gnu.org ‘home’ for this GNU project is a directory listing with 1.6.0 as
;; the latest version. The author's git repository, mentioned in the 1.6.0
;; README and otherwise legit-looking, contains a proper 1.7.0 release tarball
--
cgit 1.4.1