From 4f889375f2e3c0606e83280cd7deee5c58e11cd4 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 3 Mar 2019 17:29:56 +0200
Subject: gnu: libopenshot: Fix tests on other architectures.

* gnu/packages/video.scm (libopenshot)[source]: Add patch.
* gnu/packages/patches/libopenshot-fixup-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
---
 gnu/local.mk | 1 +
 1 file changed, 1 insertion(+)

(limited to 'gnu/local.mk')

diff --git a/gnu/local.mk b/gnu/local.mk
index c27bf9749e..974195b4bb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -976,6 +976,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/libffi-3.2.1-complex-alpha.patch		\
   %D%/packages/patches/libjxr-fix-function-signature.patch	\
   %D%/packages/patches/libjxr-fix-typos.patch			\
+  %D%/packages/patches/libopenshot-fixup-tests.patch		\
   %D%/packages/patches/libopenshot-tests-with-system-libs.patch	\
   %D%/packages/patches/libotr-test-auth-fix.patch		\
   %D%/packages/patches/libmad-armv7-thumb-pt1.patch		\
-- 
cgit 1.4.1


From e32099732c37959e2899430f833eef6558373b91 Mon Sep 17 00:00:00 2001
From: Lprndn <guix@lprndn.info>
Date: Thu, 24 Jan 2019 13:29:21 +0100
Subject: gnu: Add arcan.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/arcan.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/local.mk           |   1 +
 gnu/packages/arcan.scm | 158 +++++++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 159 insertions(+)
 create mode 100644 gnu/packages/arcan.scm

(limited to 'gnu/local.mk')

diff --git a/gnu/local.mk b/gnu/local.mk
index 974195b4bb..449ee8367d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -65,6 +65,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/antivirus.scm			\
   %D%/packages/apl.scm				\
   %D%/packages/apr.scm				\
+  %D%/packages/arcan.scm			\
   %D%/packages/aspell.scm			\
   %D%/packages/assembly.scm			\
   %D%/packages/astronomy.scm			\
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
new file mode 100644
index 0000000000..606499ba1f
--- /dev/null
+++ b/gnu/packages/arcan.scm
@@ -0,0 +1,158 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 L  p R n  d n <guix@lprndn.info>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages arcan)
+  #:use-module (guix build-system cmake)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (gnu packages apr)
+  #:use-module (gnu packages audio)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages libusb)
+  #:use-module (gnu packages lua)
+  #:use-module (gnu packages ocr)
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages ruby)
+  #:use-module (gnu packages sqlite)
+  #:use-module (gnu packages video)
+  #:use-module (gnu packages xdisorg))
+
+(define-public arcan
+  (let ((commit "b4dd1fbd1938492ff4b269189d3c8524be7450a9")
+        (revision "1"))
+    (package
+      (name "arcan")
+      (version (git-version "0.5.5.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (file-name (git-file-name name version))
+                (uri (git-reference
+                      (url "https://github.com/letoram/arcan.git")
+                      (commit commit)))
+                (sha256
+                 (base32 "1pd0avlzc2rig1hd37zbhc7r2s6fjzdhshfg9l9cfzibl7caclyw"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:configure-flags '("-DVIDEO_PLATFORM=egl-dri" "-DBUILTIN_LUA=off"
+                             "-DSTATIC_OPENAL=off""-DENABLE_LWA=on"
+                             "-DSTATIC_SQLITE3=off" "-DSTATIC_FREETYPE=off"
+                             "-DSHMIF_TUI_ACCEL=on")
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-cmake-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "src/platform/cmake/modules/FindGBMKMS.cmake"
+                 (("/usr/local/include/libdrm")
+                  (string-append (assoc-ref inputs "libdrm")
+                                 "/include/libdrm")))
+               (substitute* "src/platform/cmake/modules/FindAPR.cmake"
+                 (("/usr/local/apr/include/apr-1")
+                  (string-append (assoc-ref inputs "apr")
+                                 "/include/apr-1")))
+               #t))
+           ;; Normally, it tries to fetch patched openal with git
+           ;; but copying files manually in the right place seems to work too.
+           (add-after 'unpack 'prepare-static-openal
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((arcan-openal (assoc-ref inputs "arcan-openal")))
+                 (copy-recursively arcan-openal "external/git/openal"))
+               #t))
+           (add-after 'prepare-static-openal 'generate-man
+             (lambda _
+               (with-directory-excursion "doc"
+                 (invoke "ruby" "docgen.rb" "mangen"))
+               #t))
+           (add-before 'configure 'chdir
+             (lambda _
+               (chdir "src")
+               #t))
+           (add-after 'install 'wrap-program
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (wrap-program (string-append out "/bin/arcan")
+                   `("ARCAN_RESOURCEPATH" ":" suffix
+                     (,(string-append out "/share/arcan/resources")))
+                   `("ARCAN_STATEBASEPATH" ":" =
+                     ("$HOME/.arcan/resources/savestates"))
+                   `("ARCAN_STATEPATH" ":" =
+                     ("$HOME/.arcan/resources/savestates"))
+                   `("ARCAN_BINPATH" ":" =
+                     (,(string-append out "/bin/arcan_frameserver")))))
+               #t)))
+         #:tests? #f))
+      (native-search-paths
+       (list (search-path-specification
+              (variable "ARCAN_APPLBASEPATH")
+              (separator #f)
+              (files '("share/arcan/appl")))
+             (search-path-specification
+              (variable "ARCAN_SCRIPTPATH")
+              (separator #f)
+              (files '("share/arcan/scripts")))))
+      (inputs
+       `(("apr" ,apr)
+         ("ffmpeg" ,ffmpeg)
+         ("freetype" ,freetype)
+         ("glib" ,glib)
+         ("glu" ,glu)
+         ("harfbuzz" ,harfbuzz)
+         ("libdrm" ,libdrm)
+         ("libusb" ,libusb)
+         ("libxkbcommon" ,libxkbcommon)
+         ("lua" ,luajit)
+         ("lzip" ,lzip)
+         ("openal" ,openal)
+         ("pcre" ,pcre)
+         ("sqlite" ,sqlite)
+         ("tesseract-ocr" ,tesseract-ocr)
+         ("leptonica" ,leptonica)
+         ("vlc" ,vlc)
+         ;;  To build arcan_lwa, we need a patched version of openal.
+         ;; https://github.com/letoram/arcan/wiki/packaging
+         ("arcan-openal" ,(origin
+                            (method git-fetch)
+                            (file-name "arcan-openal-0.5.4")
+                            (uri (git-reference
+                                  (url "https://github.com/letoram/openal.git")
+                                  (commit "1c7302c580964fee9ee9e1d89ff56d24f934bdef")))
+                            (sha256
+                             (base32
+                              "0dcxcnqjkyyqdr2yk84mprvkncy5g172kfs6vc4zrkklsbkr8yi2"))))))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("ruby" ,ruby)))               ; For documentation and testing
+      (home-page "https://arcan-fe.com")
+      (synopsis "Display server, multimedia framework and game engine (egl-dri)")
+      (description "Arcan is a development framework for creating virtually
+anything from user interfaces for specialized embedded applications
+all the way to full-blown desktop environments.  At its heart lies a multimedia
+engine programmable using Lua.")
+      ;; https://github.com/letoram/arcan/blob/master/COPYING
+      (license (list license:gpl2+
+                     license:lgpl2.0
+                     license:lgpl2.0+
+                     license:public-domain
+                     license:bsd-3)))))
-- 
cgit 1.4.1


From 74fea1e2df38afc772313b3bd6658c4a337a1e1c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 4 Mar 2019 16:37:09 +0100
Subject: gnu: lyx: Remove obsolete patch.

* gnu/packages/patches/lyx-2.2.3-fix-test.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
---
 gnu/local.mk                                  |  1 -
 gnu/packages/patches/lyx-2.2.3-fix-test.patch | 13 -------------
 2 files changed, 14 deletions(-)
 delete mode 100644 gnu/packages/patches/lyx-2.2.3-fix-test.patch

(limited to 'gnu/local.mk')

diff --git a/gnu/local.mk b/gnu/local.mk
index 449ee8367d..41c10c82bc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1030,7 +1030,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/luminance-hdr-qt-printer.patch		\
   %D%/packages/patches/lvm2-static-link.patch			\
   %D%/packages/patches/lxsession-use-gapplication.patch         \
-  %D%/packages/patches/lyx-2.2.3-fix-test.patch			\
   %D%/packages/patches/make-glibc-compat.patch			\
   %D%/packages/patches/make-impure-dirs.patch			\
   %D%/packages/patches/mariadb-client-test-32bit.patch		\
diff --git a/gnu/packages/patches/lyx-2.2.3-fix-test.patch b/gnu/packages/patches/lyx-2.2.3-fix-test.patch
deleted file mode 100644
index 10b7d2a3a9..0000000000
--- a/gnu/packages/patches/lyx-2.2.3-fix-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-See https://www.lyx.org/trac/ticket/10800#comment:17
-diff --git a/src/tex2lyx/test/test-structure.lyx.lyx b/src/tex2lyx/test/test-structure.lyx.lyx
-index feff755cd2..2c7f2ace5c 100644
---- a/src/tex2lyx/test/test-structure.lyx.lyx
-+++ b/src/tex2lyx/test/test-structure.lyx.lyx
-@@ -212,7 +212,7 @@ This causes the
- \begin_inset Flex Flex:Strong
- status collapsed
- 
--\begin_layout Standard
-+\begin_layout Plain Layout
- logikalmkup
- \end_layout
-- 
cgit 1.4.1


From 96f39b2a6e03d36582108efb11f915b08c454b7c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 4 Mar 2019 17:10:28 +0100
Subject: gnu: Add java-jblas.

* gnu/packages/java-maths.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk                |  1 +
 gnu/packages/java-maths.scm | 89 +++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 90 insertions(+)
 create mode 100644 gnu/packages/java-maths.scm

(limited to 'gnu/local.mk')

diff --git a/gnu/local.mk b/gnu/local.mk
index 41c10c82bc..01addbd371 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -251,6 +251,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/iso-codes.scm			\
   %D%/packages/java.scm				\
   %D%/packages/java-compression.scm		\
+  %D%/packages/java-maths.scm			\
   %D%/packages/javascript.scm			\
   %D%/packages/jemalloc.scm			\
   %D%/packages/jrnl.scm				\
diff --git a/gnu/packages/java-maths.scm b/gnu/packages/java-maths.scm
new file mode 100644
index 0000000000..6c22f2938d
--- /dev/null
+++ b/gnu/packages/java-maths.scm
@@ -0,0 +1,89 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages java-maths)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system ant)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages gcc)
+  #:use-module (gnu packages java)
+  #:use-module (gnu packages maths)
+  #:use-module (gnu packages ruby))
+
+(define-public java-jblas
+  (package
+    (name "java-jblas")
+    (version "1.2.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mikiobraun/jblas.git")
+                    (commit (string-append "jblas-" version))))
+              (sha256
+               (base32
+                "0afh48hq8i8li5z11x415c8slwsfrlib0w1xjfbg186mximqvv3g"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; there are none
+       #:configure-flags
+       (list (string-append "--libpath="
+                            (assoc-ref %build-inputs "openblas")
+                            "/lib")
+             "--build-type=openblas")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'make-writable
+           (lambda _
+             (map make-file-writable
+                  (find-files "." ".*"))
+             #t))
+         (add-before 'build 'setenv-JAVA_HOME
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
+             #t))
+         (add-after 'build 'build-jar
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (setenv "M2_HOME" (assoc-ref outputs "out"))
+             (invoke "ant" "jar" (string-append "-Dversion=" ,version))))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((target (string-append (assoc-ref outputs "out")
+                                          "/share/java")))
+               (mkdir-p target)
+               (install-file (string-append "jblas-" ,version ".jar") target))
+             #t)))))
+    (inputs
+     `(("openblas" ,openblas)))
+    (native-inputs
+     `(("ant" ,ant)
+       ("ruby" ,ruby)                   ; for configure script
+       ("gfortran" ,gfortran)
+       ("jdk" ,icedtea "jdk")))
+    (home-page "http://jblas.org")
+    (synopsis "Linear algebra for Java")
+    (description
+     "jblas is a fast linear algebra library for Java.  jblas is based on BLAS
+and LAPACK, the de-facto industry standard for matrix computations, and uses
+state-of-the-art implementations for all its computational routines, making
+jBLAS very fast.")
+    (license license:bsd-3)))
-- 
cgit 1.4.1


From ad257ec8b578b21fc36b142396324df9e6613d4a Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 4 Mar 2019 18:36:28 +0100
Subject: gnu: thermald: Update to 1.8.

* gnu/packages/admin.scm (thermald): Update to 1.8.
[source]: Add patch.
* gnu/packages/patches/thermald-make-int-max32-visible.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
 gnu/local.mk                                       |  1 +
 gnu/packages/admin.scm                             |  7 ++++---
 .../patches/thermald-make-int-max32-visible.patch  | 24 ++++++++++++++++++++++
 3 files changed, 29 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/thermald-make-int-max32-visible.patch

(limited to 'gnu/local.mk')

diff --git a/gnu/local.mk b/gnu/local.mk
index 01addbd371..60448f9404 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1277,6 +1277,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/texi2html-document-encoding.patch	\
   %D%/packages/patches/texi2html-i18n.patch			\
   %D%/packages/patches/thefuck-test-environ.patch		\
+  %D%/packages/patches/thermald-make-int-max32-visible.patch	\
   %D%/packages/patches/tidy-CVE-2015-5522+5523.patch		\
   %D%/packages/patches/tinyxml-use-stl.patch			\
   %D%/packages/patches/tipp10-fix-compiling.patch		\
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2bc1c325a3..f425c2947c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2523,7 +2523,7 @@ make it a perfect utility on modern distros.")
 (define-public thermald
   (package
     (name "thermald")
-    (version "1.7.2")
+    (version "1.8")
     (source
      (origin
       (method git-fetch)
@@ -2532,8 +2532,9 @@ make it a perfect utility on modern distros.")
              (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
-       (base32
-        "1cs2pq8xvfnsvrhg2bxawk4kn3z1qmfrnpnhs178pvfbglzh15hc"))))
+       (base32 "1g1l7k8yxj8bl1ysdx8v6anv1s7xk9j072y44gwki70dy48n7j92"))
+      (patches
+       (search-patches "thermald-make-int-max32-visible.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
diff --git a/gnu/packages/patches/thermald-make-int-max32-visible.patch b/gnu/packages/patches/thermald-make-int-max32-visible.patch
new file mode 100644
index 0000000000..eddbb23547
--- /dev/null
+++ b/gnu/packages/patches/thermald-make-int-max32-visible.patch
@@ -0,0 +1,24 @@
+From 5fb947886bf1e40475edf930fb2b284c24c8cb9a Mon Sep 17 00:00:00 2001
+From: Sanel Zukan <karijes@users.sourceforge.net>
+Date: Sun, 23 Dec 2018 00:04:34 +0100
+Subject: [PATCH] Make sure INT_MAX32 is visible.
+
+---
+ src/thd_trip_point.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/thd_trip_point.h b/src/thd_trip_point.h
+index 0eedc95..89eb083 100644
+--- a/src/thd_trip_point.h
++++ b/src/thd_trip_point.h
+@@ -29,6 +29,10 @@
+ #include "thd_sys_fs.h"
+ #include "thd_preference.h"
+ #include "thd_cdev.h"
++
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
++
+ #include <time.h>
+ #include <vector>
+ #include <algorithm>    // std::sort
-- 
cgit 1.4.1