From 563ab27bd4caead5676bbd515c54b25100c98960 Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <m.othacehe@gmail.com>
Date: Mon, 14 May 2018 10:01:09 +0200
Subject: gnu: Add emacs-dts-mode.

* gnu/packages/emacs.scm (emacs-dts-mode): New variable.
---
 gnu/packages/emacs.scm | 26 +++++++++++++++++++++++++-
 1 file changed, 25 insertions(+), 1 deletion(-)

(limited to 'gnu/packages/emacs.scm')

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3c8475149d..4d7cdfaea5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -18,7 +18,7 @@
 ;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
-;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
@@ -10417,3 +10417,27 @@ with absolutely no stored indexes (tags) or persistent background processes.
 Dumb Jump performs best with The Silver Searcher @command{ag} or ripgrep
 @command{rg} installed.")
     (license license:gpl3+)))
+
+(define-public emacs-dts-mode
+  (let ((commit "9ee0854446dcc6c53d2b8d2941051768dba50344")
+        (revision "1"))
+    (package
+      (name "emacs-dts-mode")
+      (version (string-append "0.1.0-" revision "." (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/bgamari/dts-mode.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "1k8lljdbc90nd29xrhdrsscxavzdq532wq2mg7ljc94krj7538b1"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/bgamari/dts-mode.git")
+      (synopsis "Emacs minor mode for editing device tree files")
+      (description
+       "This package provides an Emacs minor mode for highlighting
+device tree files.")
+      (license license:gpl3+))))
-- 
cgit 1.4.1