From c0c21d77d9f0dec8ac7b49db4c4196e636728839 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Mon, 18 Jan 2021 18:27:32 +0100
Subject: gnu: Add julia-parsers.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/julia-xyz.scm (julia-parsers): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/julia-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

(limited to 'gnu/packages/julia-xyz.scm')

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b28906b546..9a615aba58 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -124,3 +124,23 @@ digits (bits) after the decimal (radix) point.")
 during iteration the @code{Ordered*} containers return items in the order in
 which they were added to the collection.")
     (license license:expat)))
+
+(define-public julia-parsers
+  (package
+    (name "julia-parsers")
+    (version "1.0.15")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaData/Parsers.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16iffl6l28kspgqch48mhi1s8qhspr3cpqcwsph3rqi72lbfqygx"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaData/Parsers.jl")
+    (synopsis "Fast parsing machinery for basic types in Julia")
+    (description "@code{Parsers.jl} is a collection of type parsers and
+utilities for Julia.")
+    (license license:expat)))
-- 
cgit 1.4.1