From 89022186256d7d0478b3e99ab664e507c6f0454b Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 1 Aug 2021 11:24:22 +0300
Subject: gnu: pcre: Fix building on riscv64-linux.

* gnu/packages/pcre.scm (pcre)[arguments]: Adjust configure-flags to not
build with JIT when building for riscv64-linux.
---
 gnu/packages/pcre.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

(limited to 'gnu/packages/pcre.scm')

diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 0324a21261..cf8c1fb2b0 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -33,6 +33,7 @@
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public pcre
@@ -62,7 +63,9 @@
                           "--enable-pcre16"
                           "--enable-pcre32"
                           ;; pcretest fails on powerpc32.
-                          ,@(if (target-ppc32?)
+                          ;; riscv64-linux is an unsupported architecture.
+                          ,@(if (or (target-ppc32?)
+                                    (target-riscv64?))
                               '()
                               `("--enable-jit")))
       #:phases (modify-phases %standard-phases
-- 
cgit 1.4.1