From c8535731b883cbc41bf42e9dc566b896726f8b17 Mon Sep 17 00:00:00 2001
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Mon, 17 Jun 2019 22:52:09 +0200
Subject: gnu: python-flask-script: Fix tests.

* gnu/packages/python-web.scm
(python-flask-script)[arguments]<#:phases>[patch-tests]: New phase.
---
 gnu/packages/python-web.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

(limited to 'gnu/packages/python-web.scm')

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d78d97c883..6fe6d5ade8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2499,6 +2499,14 @@ this it tries to be opinion-free and very extendable.")
         (base32
           "0r8w2v89nj6b9p91p495cga5m72a673l2wc0hp0zqk05j4yrc9b4"))))
   (build-system python-build-system)
+  (arguments
+   `(#:phases
+     (modify-phases %standard-phases
+       (add-after 'unpack 'patch-tests
+         (lambda _
+           (substitute* "tests.py"
+            (("flask\\.ext\\.script") "flask_script"))
+           #t)))))
   (propagated-inputs
    `(("python-flask" ,python-flask)
      ("python-argcomplete" ,python-argcomplete)
-- 
cgit 1.4.1


From 5d3675371c96fbda209b064fe3bef4a18592c3b9 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Wed, 19 Jun 2019 14:31:46 +0200
Subject: gnu: python-s3transfer: Update to 0.2.0.

* gnu/packages/python-web.scm (python-s3transfer): Update to 0.2.0.
[propagated-inputs]: Add python-urllib3.
---
 gnu/packages/python-web.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

(limited to 'gnu/packages/python-web.scm')

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6fe6d5ade8..cbcbe6c867 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2045,21 +2045,21 @@ Betamax.")
 (define-public python-s3transfer
   (package
     (name "python-s3transfer")
-    (version "0.1.13")
+    (version "0.2.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "s3transfer" version))
               (sha256
                (base32
-                "1harvyn1s8v54n1w5h7c0lg4bgjh68aylhg28s8n174q53h1ip4h"))))
+                "08fhj73b1ai52hrs2q3nggshq3pswn1gq8ch3m009cb2v2vmqggj"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             ;; 7 of the 'integration' tests require network access or login
-             ;; credentials.
+             ;; Some of the 'integration' tests require network access or
+             ;; login credentials.
              (invoke "nosetests" "--exclude=integration")
              #t)))))
     (native-inputs
@@ -2067,7 +2067,8 @@ Betamax.")
        ("python-mock" ,python-mock)
        ("python-nose" ,python-nose)))
     (propagated-inputs
-     `(("python-botocore" ,python-botocore)))
+     `(("python-botocore" ,python-botocore)
+       ("python-urllib3" ,python-urllib3)))
     (synopsis "Amazon S3 Transfer Manager")
     (description "S3transfer is a Python library for managing Amazon S3
 transfers.")
-- 
cgit 1.4.1