From b9839ee1c57455c199964bfbb212659080982c66 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Mon, 20 Dec 2021 15:13:47 -0500
Subject: gnu: python-platformdirs: Update to 2.4.0, run tests and fix
 metadata.

* gnu/packages/python-xyz.scm (python-platformdirs): Update to 2.4.0.
[phases]{pretend-version}: New phase.
{check}: Override to run tests.
[native-inputs]{python-setuptools-scm}: New input.
---
 gnu/packages/python-xyz.scm | 19 ++++++++++++++++---
 1 file changed, 16 insertions(+), 3 deletions(-)

(limited to 'gnu/packages/python-xyz.scm')

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4bb9046394..484f64a7d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27499,17 +27499,30 @@ compatible with a wide range of versions of the Stripe API.")
 (define-public python-platformdirs
   (package
     (name "python-platformdirs")
-    (version "2.2.0")
+    (version "2.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "platformdirs" version))
        (sha256
-        (base32 "07hq5qrp7pqj63iczg01wbf5ii6f0ncd0dq5mzkdhsslmg9slbb3"))))
+        (base32 "1whycrymqpsl7nsaknmcybzyh4fg4kqk6vd7zwl28kfhnf05wyin"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'pretend-version
+           ;; The version string is usually derived via setuptools-scm, but
+           ;; without the git metadata available, the version string is set to
+           ;; '0.0.0'.
+           (lambda _
+             (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" ,version)))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest")))))))
     (native-inputs
      (list python-appdirs python-pytest python-pytest-cov
-           python-pytest-mock))
+           python-pytest-mock python-setuptools-scm))
     (home-page "https://github.com/platformdirs/platformdirs")
     (synopsis "Determine the appropriate platform-specific directories")
     (description "When writing applications, finding the right location to
-- 
cgit 1.4.1