From 43cbb05f4b75ba131dfb9176e5c79f4eb7f70fd7 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sat, 13 Mar 2021 15:47:33 -0500
Subject: gnu: libtiff: Refer to the version number in a more robust way.

* gnu/packages/image.scm (libtiff)[arguments]: Replace use of VERSION
with (PACKAGE-VERSION THIS-PACKAGE).
(libtiff/fixed): Adjust accordingly.
---
 gnu/packages/image.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4f249b7622..de6872b9b2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -596,11 +596,12 @@ extracting icontainer icon files.")
               "doc"))                           ;1.3 MiB of HTML documentation
    (arguments
     ;; Instead of using --docdir, this package has its own --with-docdir.
-    `(#:configure-flags (list (string-append "--with-docdir="
-                                             (assoc-ref %outputs "doc")
-                                             "/share/doc/"
-                                             ,name "-" ,version)
-                              "--disable-static")))
+    `(#:configure-flags
+      (list (string-append "--with-docdir="
+                           (assoc-ref %outputs "doc")
+                           "/share/doc/"
+                           ,name "-" ,(package-version this-package))
+            "--disable-static")))
    (inputs `(("zlib" ,zlib)
              ("libjpeg" ,libjpeg-turbo)))
    (synopsis "Library for handling TIFF files")
@@ -625,14 +626,7 @@ collection of tools for doing simple manipulations of TIFF images.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "1jrkjv0xya9radddn8idxvs2gqzp3l2b1s8knlizmn7ad3jq817b"))))
-    (arguments
-     ;; Instead of using --docdir, this package has its own --with-docdir.
-     `(#:configure-flags (list (string-append "--with-docdir="
-                                              (assoc-ref %outputs "doc")
-                                              "/share/doc/"
-                                              ,name "-" ,version)
-                               "--disable-static")))))
+         "1jrkjv0xya9radddn8idxvs2gqzp3l2b1s8knlizmn7ad3jq817b"))))))
 
 (define-public leptonica
   (package
-- 
cgit 1.4.1