From 60a366ec7aa777d61cd349fad5f9f32cbdb642dc Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 9 Jan 2020 00:13:50 +0100
Subject: gnu: util-linux: Rename udev variant.

Some packages propagate util-linux, so make sure that that manifests and
similar choose the same version to avoid conflicts.

* gnu/packages/linux.scm (util-linux)[properties]: Remove.
(util-linux+udev)[name]: Set to "util-linux-with-udev".
[properties]: Remove.
---
 gnu/packages/linux.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3c720f32fc..ee571f12ad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1182,9 +1182,6 @@ providing the system administrator with some help in common tasks.")
 utilities.  It provides dmesg and includes tools for working with file systems,
 block devices, UUIDs, TTYs, and many other tools.")
 
-    ;; Hide the package so that end users get the udev-enabled variant below.
-    (properties '((hidden? . #t)))
-
     ;; Note that util-linux doesn't use the same license for all the
     ;; code.  GPLv2+ is the default license for a code without an
     ;; explicitly defined license.
@@ -1197,10 +1194,10 @@ block devices, UUIDs, TTYs, and many other tools.")
 (define-public util-linux+udev
   (package/inherit
    util-linux
+   (name "util-linux-with-udev")
    (inputs
     `(("udev" ,eudev)
-      ,@(package-inputs util-linux)))
-   (properties (alist-delete 'hidden? (package-properties util-linux)))))
+      ,@(package-inputs util-linux)))))
 
 (define-public ddate
   (package
-- 
cgit 1.4.1