From 9e8599a3b13d0322f8f5a7e8dfaf9f66e78139f6 Mon Sep 17 00:00:00 2001
From: Patrick Hetu <patrick.hetu@auf.org>
Date: Wed, 8 Jun 2016 13:18:07 -0400
Subject: gnu: g-wrap: Install modules to 'site/2.0'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/guile.scm (g-wrap)[arguments]: New field.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/guile.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 74e58c44af..6f00edb06b 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -939,6 +939,16 @@ capabilities.")
        ("guile-lib" ,guile-lib)))
     (inputs
      `(("libffi" ,libffi)))
+    (arguments
+      `(#:phases
+        (modify-phases %standard-phases
+          (add-before 'configure 'pre-configure
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (substitute* (find-files "." "^Makefile.in$")
+                  (("guilemoduledir =.*guile/site" all)
+                   (string-append all "/2.0")))
+                #t))))))
     (synopsis "Generate C bindings for Guile")
     (description "G-Wrap is a tool and Guile library for generating function
 wrappers for inter-language calls.  It currently only supports generating Guile
-- 
cgit 1.4.1