From f7eaa69dc2effb75ff17a2f91d6a31f3b335ee1c Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 28 Jul 2021 15:31:51 +0300
Subject: gnu: Add julia-preferences.

* gnu/packages/julia-xyz.scm (julia-preferences): New variable.
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f7a9fdb1f5..fe9d63c4a2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2902,6 +2902,31 @@ Hessian and g the gradient) may not be a descent direction if H is not positive
 definite.")
     (license license:expat)))
 
+(define-public julia-preferences
+  (package
+    (name "julia-preferences")
+    (version "1.2.2")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaPackaging/Preferences.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1cail43iqzbi6m9v6981rhz47zf2lcvhs5ds5gdqvc9nx5frghxq"))))
+    (build-system julia-build-system)
+    (arguments
+     `(#:tests? #f))        ; Tests try to mkdir /.julia
+    (home-page "https://github.com/JuliaPackaging/Preferences.jl")
+    (synopsis "Store configuration switches to TOML files")
+    (description "The @code{Preferences} package provides an integrated way for
+packages to store configuration switches to persistent TOML files, and use those
+pieces of information at both run time and compile time in Julia.  This enables
+the user to modify the behavior of a package, and have that choice reflected in
+everything from run time algorithm choice to code generation at compile time.")
+    (license license:expat)))
+
 (define-public julia-prettytables
   (package
     (name "julia-prettytables")
-- 
cgit 1.4.1